Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC:

Can't join servers version mismatch 1 year 2 months ago #7126

Hi,

Because our servers are not on 1.10.0 yet. :-) They are still 1.9.3!
Download the BTPro client from the website to always get the version of the servers which we are running.

We are planning to upgrade our servers and client to 1.10.0 soon, but as you can imagine this will take some time to make sure we covered everything with the new version. 1.10.0 only came out on the 1st of April.

So, bottom line: download the OpenTTD client from our website, then try again.

Thanks

Frank
Server Admin
The following user(s) said Thank You: tomb
  • Frank
  • Frank's Avatar Topic Author
  • Offline
  • Administrator
  • Administrator
  • Posts: 601
  • Thank you received: 315

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.031 seconds
Best hosting deal on hostgator coupon or play poker on party poker
Copyright 2020 Can't join servers version mismatch - BTPro - OpenTTD Community.